This project is read-only.

F5 debug get "An error occurred while processing your request" in IE

Jun 26, 2014 at 9:56 PM
Hi everybody,

my local dev environment is for on premise app development.
I have followed 2 article to 1) create isolated app domain 2) setup high trusted apps. I have successfully created the dummy high trusted app project in the 2nd article and see "high trust app demo site" in IE in debug mode of VisualStudio 2013.

http://msdn.microsoft.com/en-us/library/office/fp179923%28v=office.15%29.aspx
http://msdn.microsoft.com/en-us/library/office/fp179901%28v=office.15%29.aspx

However, "Core.PeoplePicker", "Core.TaxonomyMenu", "Core.TaxonomyPicker" in AMSv2.0 all give error in IE (debug mode VS2013).

Could someone guide me through what went wrong?

Thanks in advance,
MyST113
Jun 27, 2014 at 3:22 PM
Hi,
just to get some additional context. Have you tested any of the other samples and do they work or not? Would test something from the Samples folder to scope down the problem. Also any additionla details on the exact error would be useful to be able to resolve issue. ¨

Thanks for the additional details advance.
Jun 27, 2014 at 8:30 PM
Hi Vesaj,

Thanks for your words.
I have a bit progress here after ULS checking. It was "Azure access denied" information, so the core.PeoplePicker assumed to connect to Azure instead of as provider hosted.

step1
I created a new app project (named OwnApp) in VS2013, which uses certificate information as below in web.config, Then I manually copied files from core.PeoplePicker to this new project.
<add key="ClientSigningCertificatePath" value="C:\Certs\HighTrustSampleCert.pfx" />
<add key="ClientSigningCertificatePassword" value="password" />
<add key="IssuerId" value="11111111-1111-1111-1111-111111111111" />
step2
Project OwnApp launched the remote web successfully in http://localhost:22565 in IISExpress, even though the SharePoint2013 look&feel is missing, and the peoplepicker search result gives "Sorry, we had some trouble accessing your site".

step3
I modify the web.config and appmanifest.xml in core.PeoplePicker project to ensure it has same format of OwnApp ones.
Now core.PeoplePicker project gives page not found


I really could not tell any difference between the two projects (core.PeoplePicker and the one I created from scratch) except "client id" and "product id" are different.
I will study more about app creating and compare these two projects carefully, then share my findings here.

Best regards,
MyST13
Jun 28, 2014 at 9:02 PM
Edited Jun 29, 2014 at 12:57 PM
ULS tells "The Azure Access Control service is unavailable", even after web.config is set to:
<add key="ClientSigningCertificatePath" value="C:\Certs\HighTrustSampleCert.pfx" />
<add key="ClientSigningCertificatePassword" value="password" />
<add key="IssuerId" value="11111111-1111-1111-1111-111111111111" />


Could somebody tell me how the solution could use provider hosted model instead of Azure cloud? I have set the "site URL" to my local SP2013 developer site, but still this error appears in ULS.

This issue applies to all other sample codes in AMSv2.0.
Jul 2, 2014 at 8:04 AM
Hi MyST113,
Setting up high trust app model is explained in following MSDN article - http://msdn.microsoft.com/en-us/library/office/fp179901(v=office.15).aspx.

If you use VS2013 app code, you don't need to perform any updates in the code, it's rather configuration option in the web.config which will automatically then change the code to use high trust in on-premises.
Marked as answer by vesaj on 7/2/2014 at 12:04 AM
Jul 4, 2014 at 1:46 PM
Hi Vesaj,

indeed, the error roots from web.config, which allows anonymous access in the remote server,causing the spcontext = null.
once the denyuser = ? is set, the page opens successfully.

the following challenge is the js access permission from remote to sharepoint, which I will figure out by self.

Thanks for your kind help Vesaj.

having great summer,
Xi